“Could not load script.” error, in VuGen, version 2020

Question ID: 109681
0
0

When attempting to open any scripts, of any protocol, VuGen 2020 is displaying the error: “Could not load script.”

Same problem happens even for recent scripts created in VuGen 2020.
Reviewing debug logs of VuGen, we can identify some error messages referring to a specific solution (.ltsln extension file); however, that solution file does not exist on the VuGen machine as it was deleted.

Is there a solution to this issue?

Marked as spam
Posted by (Questions: 144, Answers: 1)
Asked on July 21, 2020 9:59 am
13 views
Answers (1)
1
Private answer

When VuGen is launched it tries to read the persistence files located under the AppData folder. Some of those persistence files, hold the list of recent solutions and scripts, used in VuGen.

If some solution files are deleted (outside of VuGen), this process will not update the recent items list and therefore, when starting VuGen, it will try to locate those solutions that were deleted.

Since it fails to find them, then VuGen get the exception.

In order to solve this issue, follow the below steps:

• Close all VuGen instances
• Go to the Hewlett-Packard folder under AppData folder (“C:UsersAppDataRoamingHewlett-Packard")
• Rename or delete the “LoadRunner” folder
• Once it is done, launch VuGen again and see if the problem is solved

Note: This issue is already fixed in LR2020 SP1.

Marked as spam
Posted by (Questions: 0, Answers: 152)
Answered on July 21, 2020 10:00 am