Firefox and UFT 15.00 / UFT One

Question ID: 109309
1
0

I’ve upgraded to UFT 15.0 and now Firefox is not recognized/working with UFT. Help!

Marked as spam
Posted by (Questions: 152, Answers: 22)
Asked on February 11, 2020 11:00 am
3 views
Answers
1
Private answer

Here are a few things I'd like to try that fix most issues with UFT and Firefox:

*Check for multiple agents
1. In Firefox, open the browser menu.

2. In the menu, click Add-ons.

3. In the Add-ons Manager tab, select the Extensions node.

Is there more than one UFT Agent extension listed? UFT can only communicate with one extension, and if there was a previous version of UFT installed on the machine, there may be an older extension still installed. If so, please remove the older extension.

*Make sure you are starting UFT with the Web addin selected. I know you listed you have the web addin enabled in UFT, but it didn't specify if you launch UFT first and then Firefox after UFT has opened completely.

*Start UFT by right-clicking the shortcut and selecting 'Run as administrator'

*Remove and manually install the Firefox agent:

1. In Firefox, open the browser menu.

2. In the menu, click Add-ons.

3. In the Add-ons Manager tab, select the Extensions node.

4. Click the elipses (...) next the the UFT agent, select Remove.

5. Open the InstallationsFirefox folder.

6. Drag the WebExtension.xpi file into Firefox.

7. Close Firefox

8. Close UFT

9. Launch UFT again with Web addin enabled

10. Once UFT is open, launch Firefox and test

*Try running a repair on UFT by selecting a Change operation on the UFT application in the Apps section of Windows. Select Repair and follow the screens to complete a repair.

Marked as spam
Posted by (Questions: 2, Answers: 397)
Answered on February 11, 2020 11:10 am