QC 10 to QC 11 Project Upgrade Error

  • Questions
  • QC 10 to QC 11 Project Upgrade Error
Question ID: 104576
0
0

I have been practicing my QC 10 to QC 11 upgrade and have successfully done the upgrade many times. I patched the system to QC patch 9 and now when I go to restore the QC 10 project I am receiving the following error. This all worked the previous times with no issues before patching the system.

Messages:
Failed to Restore Project;
Failed to restore project;
ALM-E10003: Physical directory ‘D:\\Program Files\\HP\\Quality Center\\repository\\qc\\ALLEGISGROUP_3_5\\IT\\’ of project ‘IT’ is unaccessible or does not exist. Make sure that the user running the service/servlet (windows/unix) has the required permissions.;

Stack Trace:
com.mercury.optane.core.CTdException: ALM-E10003: Physical directory ‘D:\\Program Files\\HP\\Quality Center\\repository\\qc\\ALLEGISGROUP_3_5\\IT\\’ of project ‘IT’ is unaccessible or does not exist. Make sure that the user running the service/servlet (windows/unix) has the required permissions.
at com.mercury.td.saserver.api.logics.CProjectLogic.restoreProject(CProjectLogic.java:1244)
wrapped in com.mercury.optane.core.CTdException: Failed to restore project….

Marked as spam
Posted by (Questions: 1, Answers: 1)
Asked on August 23, 2012 3:57 pm
38 views
Answers (3)
0
Private answer

Double-check your project's dbid.xml file and make sure the file repository directory is correct. Also, make sure you have the correct permissions for accessing the repository, whether local or networked, as per page 28 of the QC/ALM11 Installation Guide.

Marked as spam
Posted by (Questions: 0, Answers: 758)
Answered on August 23, 2012 4:39 pm
0
Private answer

Assuming the the paste of the error message is correct, all the backslash characters are missing from the Physical Directory path:

Physical directory 'D:Program FilesHPQuality CenterrepositoryqcALLEGISGROUP_3_5IT'

Check the dbid.xml file for the project and make sure the value in the Physical_Directory element is correct and valid and contains the backslashes.

Marked as spam
Posted by (Questions: 1, Answers: 101)
Answered on August 23, 2012 6:20 pm
0
Private answer

I figured out the issue. The DBA copied a DB that was already a QC 11 DB instead of a QC 10 DB. Essentially I was trying to upgrade a DB that was already upgraded :)

Marked as spam
Posted by (Questions: 1, Answers: 1)
Answered on August 24, 2012 2:08 pm