QTP 11 with Infragistics NetAdvantage/TestAdvantage – playback fails

  • Questions
  • QTP 11 with Infragistics NetAdvantage/TestAdvantage - playback fails
Question ID: 104727
0
0

We are using QTP 11 with Infragistics NetAdvantage/TestAdvantage controls. The application under test is using version 4 of the .NET framework. When I record a test with the Infragistic controls they record as generic objects instead of identified objects and playback fails. I have been in contact with Infragistics and they have been unable to resolve this issue. At this point QTP is unusable for us and my manager has instructed me to get this resolved ASAP or we will have to discontinue using the software and request a refund.

Marked as spam
Posted by (Questions: 45, Answers: 1)
Asked on November 30, 2012 8:28 am
4 views
Answers (2)
8
Private answer

Have you tried to run a repair on .NET 4.0 install. This can be done by the following.

To perform a repair:
1. Go to Add/Remove Programs
2. Select .NET
3. Select ''Change'' or the link for support information
4. When you get to the ''Maintenance Type'' screen, select Repair.

Marked as spam
Posted by (Questions: 2, Answers: 98)
Answered on November 30, 2012 8:31 am
0
Private answer

Did you purchase and install the Infragistics/TestAdvantage add-in for QTP? QTP out of the box does not recognize Infragistics controls.

Marked as spam
Posted by (Questions: 1, Answers: 101)
Answered on November 30, 2012 1:42 pm
No, I did not purchase Infragistics/TestAdvantage add-in.
( at November 30, 2012 2:15 pm)