Trouble applying QC10 Patch 28

Question ID: 104510
0
0

We are having a heck of a time getting QC10 Patch 28 to install for us.
The installer seems to think we are already at Patch 28 or higher, but we are only at Patch 25.

What gives?

Marked as spam
Posted by (Questions: 80, Answers: 5)
Asked on April 24, 2012 3:00 pm
14 views
Answers (3)
0
Private answer

Bill,

Yes, that Patch 28 has a quirk with this. It has some issues with some of the previous patches.

The best thing to do is to:

BACKUP your back-end DB,

BACKUP your repository folders

Make a backup of your current siteadmin.xml file from your (QC install path)Application20qcbin.warWeb-INF -- this file has various settings you may need.

Then, in Windows Control Panel Add-Remove Programs (or similar for your flavor of Windows), check the Updates checkbox near the top and scroll down to Quality Center 10 in the list of installed programs.
You should see all of your previous QC patches listed.

Uninstall each patch, going backward from the most recent. DO NOT uninstall QC10.
When you get to the UN-Patched QC10, then install Patch 28.
This may require some manual intervention starting and stopping the QC Service or a few retries to get the patch uninstallers to do it.

This may take a few hours of QC downtime, depending on how many patches you have installed.

Good Luck, and remember, if you feel this is over your head, ask for Tech Support to help you.

Marked as spam
Posted by (Questions: 3, Answers: 487)
Answered on April 24, 2012 3:17 pm
0
Private answer

We started uninstalling the older patches and now when we try to go into Site Admin to check our unpatched QC with Internet Explorer, we get an unsupported version error.

Marked as spam
Posted by (Questions: 191, Answers: 14)
Answered on April 25, 2012 5:24 pm
You beat us to the punch. We had the same issue with Site Administrator and IE with older patch levels.
( at April 26, 2012 12:50 am)
0
Private answer

Bill,

This happens because your IE version is much newer than what was supported with unpatched QC.
You really don't need to do it, but you can do a quick check of the patch level by going to this URL (replace with your server address).
http://yourserver:8080/qcbin/About.htm

Keep going, now install Patch 28.

Marked as spam
Posted by (Questions: 3, Answers: 487)
Answered on April 25, 2012 5:27 pm
PT, Thanks, that worked. We did have to manually start/stop the service a few times here and there, but it FINALLY installed.
( at April 26, 2012 12:51 am)