Can’t identify objects in my internal network via descriptive programming in UFT?

  • Questions
  • Can't identify objects in my internal network via descriptive programming in UFT?
Question ID: 107811
0
0

I can’t identify objects via descriptive programming in UFT. This is only happening when I try to run my scripts in my own (private) internal network. If I run the same test scripts using a normal internet environment, my descriptive programming objects are recognized just fine…just not in my own intranet environment.

Marked as spam
Posted by (Questions: 346, Answers: 13)
Asked on July 29, 2017 5:51 pm
2 views
Answers
1
Private answer

First, open one of your affected tests in UFT while you are in your internal network. Identify and remove a few of the objects from the Object Repository. Use your Object Spy to capture these same objects again from your AUT and recreate/add them to your OR. Now, take the Browser and Page parent objects from your newly recreated instances in the OR and associate them with your descriptive programming's child objects (e.g., webedit, etc.). See if these new parent objects fix your object identification issues from your intranet environment.

Marked as spam
Posted by (Questions: 0, Answers: 694)
Answered on July 29, 2017 5:52 pm
Thanks for this. Replacing and associating with new parent objects seems to have worked.
( at July 29, 2017 5:52 pm)