Error in Power BI / Excel when creating ALM Octane OData report

  • Questions
  • DevOps
  • Error in Power BI / Excel when creating ALM Octane OData report
Category:
Question ID: 109737
1
1

I have been using an OData feed from ALM Octane to pull data into Power BI for about 3 months. This week however, refreshing the data source has been giving me 404 errors. After entering the URL to access the data, I can select the ‘Story’ table view the data with no problems. When I try to commit these changes (Close and Apply), I receive the 404 error. I tested pulling the OData into excel, and I received the same error. It was working perfectly fine until this week, and I have made no changes to the Power BI settings and configurations. Right now, the ODATA_MAX_PARAMETERS_FOR_DB_QUERY parameter is set to the default value of 1000.

Marked as spam
Posted by (Questions: 217, Answers: 21)
Asked on July 31, 2020 11:37 am
11 views
Answers (1)
1
Private answer

Hello. I have seen this behavior before. I would like for you to increase the value for the ODATA_MAX_PARAMETERS_FOR_DB_QUERY parameter to a higher value than the default 1000. After changing the parameter value, you will need to restart the octane server for the change to take effect. After you have increased the parameter value, and restarted the server, retest to see if the issue still occurs.

Marked as spam
Posted by (Questions: 2, Answers: 278)
Answered on July 31, 2020 11:38 am
Looks like the data is pulling in now. I think it was changing the query limit to 1000 to 10000. Thanks for your help.
( at July 31, 2020 11:39 am)