Getting ”Server Muted” error after changing Base Repository path

  • Questions
  • Getting ''Server Muted'' error after changing Base Repository path
Question ID: 105292
0
0

We just installed ALM11.52 and everything was working fine and we were able to get into site admin.

THEN, we decided to change the site parameter for REPOSITORY_BASE_PATH to a location on our server’s "D" drive instead of the default that was on "C".

When we stopped and re-started the HP ALM Service, and we tried to launch Site Admin, we got a "Server Muted" page and could not get into QC anymore.

What happened? Can this be salvaged?

Marked as spam
Posted by (Questions: 187, Answers: 13)
Asked on February 4, 2014 11:17 pm
5 views
Answers (3)
1
Private answer

GoBroncos,

When you get a ''Server Muted'' page instead of the ''qcbin'', Site Admin, or QC Client pages, it is usually related to DB or file system lack of communication.

In your case, since you tried pointing it to a DIFFERENT location for the repository, you need to make sure of a few things:

1) that the new repository folder exists,

2) it has the ''qc'' folder (which contains ''Default'' folder and other various domain folders if you have any), and a txt file (dbcon.txt),

3) it also has copies of the ''SA'', ''CustomerData'', ''import'' folders, and versions.xml

After doing this, start the services and Site Admin (everything else) should now come up again with IE.

Basically, you could copy the contents of the old ''repository'' folder to the NEW location.

Now, to get/move old/existing projects into the NEW repository location, you would need to ''remove'' them from Site Admin, move (or confirm they exist) the various project repository folders to the NEW location under the correct domain folder in the NEW repository folder structure, the edit the DBID.xml file for each project so it's Project Directory points to the new folder, then ''restore'' each project with Site Admin.

P.S. sorry about the superbowl.

Marked as spam
Posted by (Questions: 3, Answers: 472)
Answered on February 4, 2014 11:35 pm
We had a NEW server without any new or migrated projects. After copying the contents of the old repository folder, it started working, thanks. About the superbowl, we blew it.
( at February 4, 2014 11:37 pm)
0
Private answer

Another (preferred) method is to re-run Configuration Wizard (existing settings/connect to existing qcsiteadmin_db) and specify the NEW repository location.

This method also will create a NEW/blank LAB_PROJECT so if using an Enterprise QC11.5x or 12.x license, everything will work as before (you had a blank LAB_PROJECT before anyway and could not use it or see it).

This method also requires Configuration Wizard to make it through all screens (you may need to find the license files) and it may have issues with re-connecting to an existing qcsiteadmin_db. Then it can take a long time to deploy and start the application (20 minutes or longer).

Marked as spam
Posted by (Questions: 3, Answers: 472)
Answered on July 17, 2015 8:32 pm
0
Private answer

![alt text][1]

[1]: /storage/temp/317-servermuted.png

When I change my BASE_REPOSITORY_PATH to an invalid path, this is the way the Server Muted page looks.
No JAVA error reported, but white-space.

Marked as spam
Posted by (Questions: 3, Answers: 472)
Answered on August 7, 2015 2:44 pm