Help with Insight Objects UFT GUI

Question ID: 108023
1
0

I am recording an object using the Insight Object recording method. It works fine when running the test locally. It shows the actual Insight object recorded, but when I try to call that test from another test it will not recognize the Insight Object. I have tried adding it to both the local and shared repository in the local test and have done the same for the test that I am calling it from to no avail. Again, it works fine until I call the test with the Insight object from another test. Please advise. Thank you.

Marked as spam
Posted by (Questions: 22, Answers: 6)
Asked on December 12, 2017 10:10 pm
11 views
Answers (1)
0
Private answer

I had interesting issue kind of like this, I have dual monitors. When I run the script locally and manually launch the app, I always run it on my primary monitor. When I call it from another script which is where the problem is, the app is launched via Command Line Interface (CLI). When the app is launched via CLI, it opens the app on my secondary monitor. It will not recognize the insight object on my secondary monitor. If I run the script again via CLI and then drag the app over to my primary monitor the insight object is recognized. Insight objects must be ran on the primary monitor or they are not recognized.

Marked as spam
Posted by (Questions: 2, Answers: 98)
Answered on December 12, 2017 10:10 pm