IE9 Memory increases till crashing

Question ID: 105326
1
0

I am on IE9 and UFT 11.53 and when I run my test, IE9 memory consumption rises exponentially, eventually crashing! What do we do to fix this??

Marked as spam
Posted by (Questions: 380, Answers: 57)
Asked on March 12, 2014 12:35 pm
17 views
Answers (2)
1
Private answer

Please try this and let me know the results. I recommend commenting and renaming vs. deleting so this procedure can be reversed if it does not work or has other adverse affects:

1. Close UFT any open browser.

2. Go to datExtensibilityWebToolkits

3. For each Toolkit (Dojo, GWT, HPInternal, JQueryUI, etc) look for the file called: .xml

Example:

- Dojo: C:Program Files (x86)HPUnified Functional TestingdatExtensibilityWebToolkitsDojoDojo.xml
- GWT: C:Program Files (x86)HPUnified Functional TestingdatExtensibilityWebToolkitsGWTGWT.xml

4. Open the XML File

5. Comment () or Remove the following lines:
<JSLibrariesToInject/>
<JSLibrary path=''INSTALLDIRbinJSFilesjQuery-1.3.2.js''/>
<JSLibrary path=''INSTALLDIRbinJSFilesjQuery.simulate.js''/>
</JSLibrariesToInject/>
6. Go to: binJSFiles

7. Compress the files to use them as Backup

- jquery.simulate.js
- jquery-1.3.2.js

8. Delete or rename the files you compressed in step #7

HP statement on this procedure:
The XMLs and JS files belongs to the JQuery and JQueryUI libraries used by UFT in order to interact with COM and provide support for Web Objects part of: Web Add-in and Web 2.0

This libraries has been updated in UFT 11.53 and depending of the JS libraries used by the AUT they could generate a conflict and cause a high consume of memory. Once you disable JQuery libraries from UFT you are using AUT's libraries.

This probably will not affect the interaction between UFT and this AUT, however if the tool is used against other AUT who require JQuery from UFT side probably will not have recognition.

Marked as spam
Posted by (Questions: 16, Answers: 801)
Answered on March 12, 2014 12:51 pm
That worked great!! Thanks!!
( at March 12, 2014 12:52 pm)
0
Private answer

Hello I have the same problem on uft 12.02 I tried to comment the lines but on this uft version these Toolkits are apperently not present under the same directories could anybody help me?

Thanks

Marked as spam
Posted by (Questions: 0, Answers: 1)
Answered on November 28, 2016 9:06 am