Inconsistent object recognition

Question ID: 105626
1
0

There are a number of instances where QTP shows inconsistency on recognizing object properties. When an object is added to the Shared Object Repository or an object is added via recording, we will see a number of object properties get stored along with their values.
On playback, these objects are recognized and QTP works just fine on several iterations. Then suddenly QTP can no longer see the value of a particular property and just fails on it. Eliminating that property from the repository is usually not an option because the other properties are insufficient to establish unique recognition (meaning that there are other objects of the same class with the same values for the other properties)
Why is this inconsistency happening?
Is there some configuration in object recognition or object identification that can alleviate this problem? We are working with a Visual Basic 6 application in a client server environment and I am using the Visual Basic Add-In only. No other Add In is loaded or enabled.

Marked as spam
Posted by (Questions: 45, Answers: 0)
Asked on October 22, 2014 6:31 pm
7 views
Answers (1)
1
Private answer

I have seen similar issue before. Is QTP being started before after application under test? Somehow, the ''Run and recording settings'' were change to only look at objects started by QTP. Changing the ''Run and recording settings'' to look at all process solved this issue.

Marked as spam
Posted by (Questions: 2, Answers: 98)
Answered on October 22, 2014 6:32 pm