Launch Report button is disabled in ALM

  • Questions
  • Launch Report button is disabled in ALM
Question ID: 107863
1
0

After running a UFT test, we find that the Launch Report button is disabled in Test Lab within ALM. I’ve tried rerunning both HPE ALM Connectivity and HPE ALM Client Registration and resetting IE’s settings to factory original. I have tried deleting the TD_80 folder, and renaming the xml files in the %appdata%/roaming/hp directory, as we have seen this resolve issues within UFT in the past, but nothing has resolved the issue in ALM. The machine was rebooted after trying the HPE tools. The Results Viewer opens when started independently, but I don’t see an option in the report to connect to ALM. I also did a test run in UFT and the Results Viewer opens from there and shows results as expected. We are currently using the ALM Client on the same machine where UFT is installed.

Marked as spam
Posted by (Questions: 219, Answers: 23)
Asked on September 15, 2017 4:52 pm
109 views
Answers (1)
1
Private answer

Typically, when the 'Launch Report' button is disabled in ALM when the Client is being used on the same machine where UFT is installed, it is due to the ALM add-in not being installed on the UFT machine. I have listed the steps below to install the ALM add-in on the UFT machine.

Steps to install the UFT/ALM add-in on your ALM Client machine (With UFT Installed):

Close the instances of ALM and UFT on the machine. If you are installing the UFT/ALM add-in on the machine where UFT is currently installed, you will need to access Programs and Features (Control PanelAll Control Panel ItemsPrograms and Features), right-click on 'HPE Unified Functional Testing' and select 'Change' in the toolbar. In the 'HPE Unified Functional Testing Setup' window, follow the steps to change the features that are currently installed. In the 'Custom Setup' window, you will need to click the drop down for the 'ALM Plugin' option and select for it to be installed on the machine. After you have selected the ALM Plugin to be installed, complete the change process and close the 'Programs and Features' window. Open ALM and UFT and retest to see if the 'Launch Report' button is still disabled.

Marked as spam
Posted by (Questions: 2, Answers: 280)
Answered on September 15, 2017 4:54 pm
Thanks! That resolved the issue. The Launch Report button is now enabled in ALM, and we are able to access the report.
( at September 15, 2017 4:54 pm)