LeanFT Test builds with no errors but won’t run???

  • Questions
  • LeanFT Test builds with no errors but won't run???
Question ID: 106331
1
0

When I run my LeanFT test in Visual Studio, it builds with no errors but nothing happens. I can’t figure out what’s going on. I have spent hours on this and can’t resolve it.

Marked as spam
Posted by (Questions: 339, Answers: 20)
Asked on August 12, 2015 11:21 pm
4 views
Answers (1)
1
Private answer

This can happen if your project is on a network shared drive or a VM environment where your project is located on the host machine.
In Visual Studio, go to View>Other Windows>Output and see if you have a message like:

> Could not load file or assembly
> '{projectPath}\{project}.dll' or one
> of its dependencies. Operation is not
> supported. (Exception from HRESULT:
> 0x80131515)

To fix it, open a command prompt and type:

setx COMPLUS_LoadFromRemoteSources 1

As an alternative,

- Create an environment variable named COMPLUS_LoadFromRemoteSources
- Set the value to 1
- Restart Studio

(source: http://b2ben.blogspot.com/2014/07/running-visual-studio-tests-from.html, be sure to see the note at the bottom regarding the devenv.exe.config file. Did not work for me either.)

Marked as spam
Posted by (Questions: 16, Answers: 749)
Answered on August 12, 2015 11:23 pm
Wow I would never have known to do that! It worked! Thanks!
( at August 12, 2015 11:24 pm)