QC Sync won’t connnect to QC now, but just did yesterday

  • Questions
  • QC Sync won't connnect to QC now, but just did yesterday
Question ID: 105554
0
0

We have been making some simple changes to our links (tweaking mappings) and also have been cycling the QC-Sync services a bunch of times today.
We did not do any patching or other QC changes lately.
Our QC Client can connect to our QC project (from the QC-Sync server) and has had "Register ALM Client" run (again).

We noticed that a cycle of the QC Server/services solves the issue and we can connect again with connectivity to QC from QC-Sync.

We must have had a "hung session", has anyone seen this before?

Marked as spam
Posted by (Questions: 74, Answers: 4)
Asked on July 31, 2014 4:18 pm
5 views
Answers (1)
1
Private answer

Yes, I have seen the QC Server where an ''API Client'' (like the way QC-Sync communicates with QC) can pile up too many connections to the QC Server.
Sometimes it gets ''hung'' and refused future connections. This can be resolved by the QC Admin selecting the connection from the Site Admin tool and clearing it --- or with a cycle of QC services on the QC server.

I saw this when trying to get some VB script code to communicate via API with QC and after some ''cycles'' of my script (when running it many times), it would ''hang'' that connection and future connections attempted from my script until I cycled QC services.

Let's hope this does not happen with your QC-Sync setup going forward - I have never seen it required for QC-Sync before.

Marked as spam
Posted by (Questions: 3, Answers: 466)
Answered on July 31, 2014 4:22 pm
That worked, Thanks. I guess the old adage ''When in doubt, reboot... or cycle QC services'' applies again here.
( at July 31, 2014 4:24 pm)