QC10 error ”A call to an OS function failed”

  • Questions
  • QC10 error ''A call to an OS function failed''
Question ID: 104734
1
0

When working with Test Cases, I keep getting a red box with an error message ‘A call to an OS function failed.’

Any help?

Marked as spam
Posted by (Questions: 359, Answers: 26)
Asked on December 3, 2012 10:52 am
11 views
Answers (1)
2
Private answer

This is due either to corrupt QC client components or conflicting applications on the client machine. It is most likely because of an Internet Explorer toolbar or add-in.

Give this a try:

1) First, try uninstalling the QC client components using the QC Client Uninstall Utility:
[http://support.openview.hp.com/selfsolve/document/KM1400068
][1]

2) If the problem still persists, remove the ''MSN Toolbar'' or ''Web Discussion'' toolbar from the client machine (IE -> View -> UNCHECK 'Discuss' under Explorer Bars).

3) Take a look at the list of Windows applications that are known to conflict with the QC Client and remove/disable as appropriate:
[http://support.openview.hp.com/selfsolve/document/KM176429][2]

4) If the user wants an alternative to removing conflicting applications, try using QC Explorer instead of IE (found in the Add-ins Page).

Reference:
[http://support.openview.hp.com/selfsolve/document/KM195818][3]

[1]: http://support.openview.hp.com/selfsolve/document/KM1400068
[2]: http://support.openview.hp.com/selfsolve/document/KM176429
[3]: http://support.openview.hp.com/selfsolve/document/KM195818

Marked as spam
Posted by (Questions: 0, Answers: 707)
Answered on December 3, 2012 10:58 am
Removed ''Web Discussion'' from my browser and it worked! Thanks!
( at December 3, 2012 11:01 am)