QTP crashes when copying text?

Tags:
Question ID: 104617
1
0

I have a script that I’ve copied 10 lines of checkpoints numerous times that now crashes QTP when trying to copy (Edit-Copy, Ctrl-C). The error is ‘This operation cannot be performed. For further help please contact support’. Clicked OK and another message appears. Second error is a "’Slick-C Error’ — Variable element or variable not initialized. file=util.ex offset=3295". At that point QTP locks up and task manager is used to close QTP.
Tried copying the script from QC to a local drive, but the same error appears. Tried deleting a good portion of the test, but the same error appears.

This is isolated to one test and not any other test.

Marked as spam
Posted by (Questions: 45, Answers: 0)
Asked on September 27, 2012 8:40 am
17 views
Answers (1)
3
Private answer

I had the similar problem a while back. I am not sure how but the Local Object Repository (LOR) was corrupted. The corruption could be related to the Trademark ™ character in the objects attributes or restructuring the OR. I could export LOR and recover my repository.

Here are your option.

1. Export LOR to Shared Object Repository (SOR) and use SOR.
2. Rebuild test with new LOR.

Marked as spam
Posted by (Questions: 2, Answers: 98)
Answered on September 27, 2012 8:50 am