Some of my TruClient scripts fail to run or get stuck in the initializing in PC 12.50

  • Questions
  • Some of my TruClient scripts fail to run or get stuck in the initializing in PC 12.50
Question ID: 107578
0
0

I have 10 TruClient scripts that work in VUGEN – 50% Fail to Run in PC. When transferred to ALM Performance Center. Some of these scripts function and some do not make it to the Run Stage. The Vusers initialize but they Timeout because they have not progressed to run the script.

– Scripts are created in VUGEN 12.53 Build 1203.
– Scripts are TruClient Web – using Chromium protocol for design
– The ALM – PC version is 12.50 (no patches)
– The Load Generators have settings for TruClient Protocol – I think this is referred to as "Agent As Process"

Any assistance would be greatly appreciated.

Marked as spam
Posted by (Questions: 216, Answers: 15)
Asked on April 21, 2017 12:20 pm
33 views
Answers (1)
0
Private answer

Hello,

Frist, you **must upgrade** the **ALM-PC machines (all of them) to version 12.53**, if you want ** to ensure that scripts created in VuGen 12.53 will properly.**

Scripts created in a newer/higher version of VuGen will normally fail to work in older/ lower version of the Performance Center/ LoadRunner controllor.

You can run older scripts, i.e. **VuGen 12.50**, in the newer version PC/LoadRunner (i.e. **ALM-PC 12.53)**

I also **Highly recommended applying PC/LR patch 4** to you **PC 12.53 environment** & **VuGens** machine as the a several major fix to the TruClient Protocol in that patch set.

Marked as spam
Posted by (Questions: 12, Answers: 361)
Answered on April 21, 2017 12:27 pm