Timeout during project creation in ALM?

  • Questions
  • Timeout during project creation in ALM?
Question ID: 108789
0
0

Hello,
We are having an issue where during project creation in ALM the siteadmin process times out and fails. This anomaly is only occurring on the siteadmin that are run remotely and when on the server the project creates normally and without issue. We think it may be a timing issue related to the remote usage (could be internet lag, groups policies slowing the data, etc). We have no idea where to start and would like to resolve the issue if there is a change that can be easily made?

Thanks for any assistance,
HomerJ

Marked as spam
Posted by (Questions: 314, Answers: 12)
Asked on January 10, 2019 3:33 pm
9 views
Answers (3)
1
Private answer

Hi HomerJ,
I have encountered this in the past and an adjustment recommended by Microfocus after testing with the client found that adjusting the timeout settings within the jetty.xml files had a positive result. The following was what was recommend to be changed:

Please try the below steps:

*In ALM Server (ALL YOUR NODES if running multiple servers) Open ''jetty.xml'' file.

This is typically located in the path: ProgramDataHPALMserverconfjetty.xml

*Open the file for editing and search for ''
*If you have a value of 30000. That's measured in ms.

*Increase this to 600000, save, then bounce the ALM service''

This was a suggestion that worked for a client in the past and if the increases after multiple tries yields nor positive results you may look into the network settings with your IT department to see if there is a slow down being caused by something in the network. At least you have the server portion to use as a work around in your instance,

Hope this helps,
Dan

Marked as spam
Posted by (Questions: 0, Answers: 709)
Answered on January 10, 2019 3:40 pm
@Dan , to your point where you have mentioned ''may look into the network settings with your IT department to see if there is a slow down being caused by something in the network'' What should we ask to Network Engineer? What should they look into? This is because, I have seen where Network Er tested the network readability just doing ''ping'' or ''traceroute''. Ping or traceroute wont really help us to yes network on server is as expected. So what should Network Er. look into troubleshoot the slowness or Timeout issue in ALM. Thank you in advance for your input.
( at January 10, 2019 7:31 pm)
0
Private answer

@miraclefren2 Ping will tell the reliability of the signal and how it is reproduceable when run connsecutively. Tracert can reveal a slow or weak hop which could be a router/switch/hub/cabling error that is causing such issue. You could try wireshark for checking packet loss too. They need to look at the overall signal and path and see that it is not just ''working'' but ''working efficiently'' . Just getting there is not always good enough with data, as how much error correcting must happen among other things. they should be able to trouble shoot the network to locate it and if they have mapped it correctly then they should have performance stats and be maintaining these for historical data comparison to find failure in advance.

Marked as spam
Posted by (Questions: 0, Answers: 709)
Answered on January 10, 2019 8:08 pm
@Dan, my ALM 12.55 and ALM 12.60 are installed in LINUX without GUI interface. Unfortunately, Wireshark is not supported in LINUX if the server does not have GUI interface. SO, what I did was I ran the ''tcpdump'' cmd in Linux and captured a network log into a file. But, that really did not help much. Because Network Er. ran ping and traceroute cmd said server has good network status. However, project creation issue in ALM 12.55 and ALm12.60 is still there.
( at January 10, 2019 8:25 pm)
0
Private answer

@miraclefren2 . Wireshark being supported in Linux or not should be a moot point, if you aren't having issues creating projects on the server directly, As that connectivity is working correctly. If you are having issues creating it on the server where it is timing out then you need to find a Linux tool to assist. Otherwise the wireshark can be run on a remote system testing the routing to the server as that is the link we are talking about with the above error. You could elevate the logs to debug level and then watch the commands created and compare the timing and differences between the project creations attempted on the server versus those on the remote system. If you can't create projects on either and it isn't a timeout issue then you need to be looking into permissions on the DB supporting the ALM application. You should probably open a case with your support provider to further trouble shoot this issue.

Marked as spam
Posted by (Questions: 0, Answers: 709)
Answered on January 10, 2019 8:38 pm