UFT cannot connect to ALM

Question ID: 105489
1
0

UFT will not connect to ALM. Win7 64, UFT 11.53, IE9. Error:

Failed to update components from server
Failure in Spider Module Process. Error: Following client components were not
downloaded successfully:

1 . MMerge.exe:
Cannot download. Check this file is present on server.

Close all connections to Server and try again.

Marked as spam
Posted by (Questions: 359, Answers: 26)
Asked on July 10, 2014 8:04 pm
12 views
Answers (1)
1
Private answer

Normally, when either UFT or your ALM client browser complains about not being able to download client components from the ALM server, it's a sign of these components being ''hijacked'' due to anti-virus and/or anti-malware software actively scanning and possibly quarantining these components. Make sure your anti-virus/anti-malware software has exceptions for the following on your client machine:

%TEMP%TD_80

C:Program Files (x86)Common FilesMercury Interactive

%LOCALAPPDATA%HP

%ALLUSERSPROFILE%HP

Also, install the HP ALM Connectivity Tool and register your ALM client (both from the ALM Tools page).

You can confirm whether or not the files successfully download from the server by checking the ALM Client file paths to see of the files appear (in your case, MMerge.exe):

`%LOCALAPPDATA%HPALM-Clientatlhpalm` (if current user)

`%ALLUSERSPROFILE%HPALM-Clientatlhpalm` (if all users)

Marked as spam
Posted by (Questions: 0, Answers: 707)
Answered on July 10, 2014 8:04 pm
That was absolutely it. Our company runs Kaspersky, and it was blocking our clients from downloading from the QC/ALM server. Thanks!
( at July 10, 2014 8:05 pm)