UFT erroring on my variable name

Category:
Question ID: 109029
1
0

I tried to use a variable Link as

Link = "http://www.Google.com"

but got an error stating

> "Object doesn’t support this property
> or method: ‘Link"’

.

How can I fix this and why does it not work??

Marked as spam
Posted by (Questions: 339, Answers: 20)
Asked on May 15, 2019 6:33 pm
4 views
Answers (1)
1
Private answer

It doesn't work because Link is a reserved word in UFT. Change it to MyLink and it should work just fine.

Things like Link, Image, Browser, WebButton, etc. are Test Object Classes. Per [UFT documentaion][1], ''Reserved words in UFT include the names of all UFT test object classes, methods, and properties, as well as F-keys (F1, F2, and so on).''

You can check the [UFT Object Model Referenc For GUI Testing][2] to find all the object classes, mehtods and properties for the various technologies.

[2]: https://admhelp.microfocus.com/uft/en/14.50-14.52/UFT_Help/Subsystems/FunctionReference/Subsystems/OMRHelp/OMRHelp.htm#OV_Supp_Util/Overview.htm%3FTocPath%3DObject%2520Model%2520Reference%2520for%2520GUI%2520Testing%7C_____0

[1]: https://admhelp.microfocus.com/uft/en/14.50-14.52/UFT_Help/Content/User_Guide/vbscript_rules_guideines.htm

Marked as spam
Posted by (Questions: 16, Answers: 749)
Answered on May 15, 2019 6:34 pm
I changed it to MyLink and it worked. Thanks for the information.
( at May 15, 2019 6:36 pm)