When opening test cases, the steps disappear after upgrading QC10 project to ALM11?

  • Questions
  • When opening test cases, the steps disappear after upgrading QC10 project to ALM11?
Question ID: 105014
0
0

Hello,
I have recently migrated a project from our QC10 instance to our ALM11 instance. After the migration when I check out the test cases, the steps are empty. If I immediately check in the test cases, the steps reappear again. DO you have any idea how to fix this or what may have happened, as other project migrated do not have this issue, although they are not using Version control like this one?

Thanks,
HomerJ

Marked as spam
Posted by (Questions: 314, Answers: 12)
Asked on May 15, 2013 6:02 pm
7 views
Answers (1)
1
Private answer

Hi HomerJ,
I have seen this issue when the projects were not fully checked in and the version control disabled before the migration. It is possible to that the dvid.xml file was not edited correctly during the migration and the version control references were left in the file, or not edited to be off. Since your other projects are not using version control and are unaffected, then I would guess that this is the issue.

I have seen in other issues where toggling the version control setting can fix this error as it runs a history clean up during the process. What you would do is toggle the VC off so it runs the clean up, and then turn it back on to re-enable it.

Before trying this, I would be sure that the project is fully migrated (from within site admin: Tool>Repository Migration Status menus to get that information) and I would run the verification and repair on the project to insure that nothing else is the root cause.

I hope this help with the issue.

Dan

Marked as spam
Posted by (Questions: 0, Answers: 709)
Answered on May 15, 2013 6:08 pm
We verified and repaired the projects and they were all passed without issue. We then tried the toggling of version control as suggested and it is now working correctly again. Thanks!!
( at May 15, 2013 6:10 pm)