Windows application with browser objects not working with LeanFT

  • Questions
  • Windows application with browser objects not working with LeanFT
Question ID: 107074
1
0

We have a Windows based application that has browser based controls in it. We are having trouble getting LeanFT to work with this application. I know with UFT we had to go through a special procedure mentioned in HPE document KM00361246. Is there something we need to do for LeanFT?

Marked as spam
Posted by (Questions: 384, Answers: 61)
Asked on August 25, 2016 9:50 pm
103 views
Answers (1)
1
Private answer

You can find instructions on how to get LeanFT to work with embedded browser controls at this link:

http://leanft-help.saas.hpe.com/en/12.52/HelpCenter/Content/HowTo/WebApps.htm#BrowserControls

> Register embedded browser controls If
> you have a non-Web application that
> hosts a browser control, you must
> register the control so that the
> LeanFT runtime engine can recognize
> the objects inside as Web objects. You
> must register the browser control with
> LeanFT on any computer where you want
> to run your tests or use the Object
> Identification Center. You register
> the control using the Register Browser
> Control Utility. Note: This utility
> supports browser controls that are
> based on the Internet Explorer engine
> . Make sure UACis disabled while
> using the utility or run the utility
> executable using Run As Admin. Run the
> Register Browser Control Utility
> from
>
>
> `LeanFT installation folderbinSettingNewBrowserControlApplication.exe`
>
>
> Enter the path of the application
> containing the browser control and
> click Register. Restart the LeanFT
> runtime engine.

> If needed, you can run
> this utility again at a later time to
> unregister the browser control.

Marked as spam
Posted by (Questions: 16, Answers: 806)
Answered on August 25, 2016 9:52 pm
Thank you, that process made it work.
( at August 25, 2016 9:53 pm)
EyeOnTesting