Questions for tag "api" (94)

Votes
Answers
Views
Question
1
vote
1
answer
0
views
asked 1 year ago by
updated 1 year ago by
Category: Test Automation
My API test calls a GUI test. After running the GUI test, it won't continue running iterations. The first iteration runs without a problem, but subsequent iterations hang and never complete. It happen...
2
votes
1
answer
0
views
asked 1 year ago by
updated 1 year ago by
Category: Test Automation
We're just beginning to look into testing IoT (Internet of Things) devices. Does anyone have some tips for doing this with UFT?
0
votes
1
answer
5
views
asked 1 year ago by
updated 1 year ago by
I'm just trying to find out how to pass ODBC connection parameter from one test to the next test either with custom code or using a test output parameter.
2
votes
1
answer
2
views
asked 1 year ago by
updated 1 year ago by
Need my API test to create a folder to write some files into during the test. Is there an activity to do this? There seems to be one for Files but I can't seem to find one for folder.
2
votes
1
answer
4
views
asked 1 year ago by
updated 1 year ago by
Using UFT 14.03, when downloading a WSDL definition, we are getting the error "The request was aborted: Could not create SSL/TLS secure channel." in an API test. In SoapUI we can download with...
2
votes
1
answer
4
views
asked 1 year ago by
updated 1 year ago by
Running API test locally from UFT and I get a pass but when I run the same test from ALM locally I get failure. I cannot get ALM to show the test results to trouble shoot issue. Does anybody have idea...
1
vote
1
answer
3
views
asked 1 year ago by
updated 1 year ago by
Hello, We have an nightly api test script that is run from a batch file and it is not working correctly after the upgrade we performed on the ALM system. We are getting a "server is not available ...
0
votes
1
answer
3
views
asked 1 year ago by
updated 1 year ago by
It is my understanding that workflow does not execute for Excel Imports or using the API say for creating defects. Meaning in the browser using workflow I can make one field required based on the valu...
2
votes
1
answer
1
view
asked 1 year ago by
updated 1 year ago by
When we import our WSDL into a UFT API test, we get our server information in the activity's HTTP Endpoint Address field. (For example, if you use the UFT Flights Service API that comes with UFT, and ...
2
votes
1
answer
3
views
asked 1 year ago by
updated 1 year ago by
We are seeing an issue with UFT removing links from child nodes to the Start node in API tests. Our steps to reproduce (we have seen this done with other WSDLs too, for example the Flight API sample f...
2
votes
1
answer
3
views
asked 1 year ago by
updated 1 year ago by
In our API test, we're seeing the following error, "The underlying connection was closed: An unexpected error occurred on a send." So far my troubleshooting has been fruitless. Does anyone kno...
2
votes
1
answer
4
views
asked 2 years ago by
updated 2 years ago by
On v14.00 we are unable to open tests that were created with an older version. Example: 12.52 build 5282. Errors presented upon loading the test from ALM. Version 12.55.358 (Patch 1). Are the scripts ...
2
votes
1
answer
1
view
asked 2 years ago by
updated 2 years ago by
I need to send an email from an API test with UFT. Can't seem to figure out how to do it, even with custom code.
2
votes
1
answer
1
view
asked 2 years ago by
updated 2 years ago by
I have a couple of optional fields in my REST API test. I'm using the keyword #SKIP# in my Excel file to omit the field in the request. My problem is that the fields aren't being omitted, instead they...
2
votes
1
answer
1
view
asked 2 years ago by
updated 2 years ago by
We're using the XmlToString activity. We have an output parameter in the Start node. We have the output parameter linked to the XmlToString Result Parameter. After running the test, the report results...
1 2 3 7