ALM 12.21 pending upgrade of Oracle – version compatibility question

  • Questions
  • ALM 12.21 pending upgrade of Oracle - version compatibility question
Question ID: 108621
0
0

Good Afternoon,

We are upgrading our Oracle database to 12.2.0.1. Currently we have ALM 12.21 patch 02. Please advise if ALM 12.21 patch 02 is able to work with Oracle 12.2.0.1.

Thank you

Marked as spam
Posted by (Questions: 91, Answers: 6)
Asked on September 19, 2018 2:55 pm
11 views
Answers (1)
0
Private answer

Sorry, the latest Oracle version supported by QC/ALM 12.21 is Oracle 12.1.0.2.

According to the system requirements :

https://admhelp.microfocus.com/alm/specs/alm-qc-system-requirements.htm#ALM1250

Oracle 12.2.x requires ALM 12.55 Patch 2 or later.

So, if you **MUST** upgrade Oracle to 12.2.x, then you will also need to upgrade Quality Center as well.

Marked as spam
Posted by (Questions: 3, Answers: 466)
Answered on September 19, 2018 2:56 pm
Will it work even if it's not supported? If we see something not working right, then we should upgrade?
( at September 19, 2018 3:20 pm)
When it says it is not supported, HPE/MF usually backs that up with some internal check for the version. Sometimes we can defeat the DB version check, but lately, with ALM12.xx, even those don't seems to work any longer. Also, if you upgrade your Oracle Schemas, generally, you cannot go backward to the previous version. If your organization pushes you about upgrading Oracle to a version (12.2.x) not supported by 12.21, then you will need to also upgrade QC/ALM to 12.55 Patch 2.
( at September 19, 2018 3:24 pm)