APLS Server Not Available

Question ID: 108011
2
0

Even though our port (5814) is not blocked, and we can access the AutoPass License Server (APLS) dashboard from the browser, when we try to get a license from UFT we are getting the message "Autopass Server Not Available".

Any ideas on how to fix?

Marked as spam
Posted by (Questions: 380, Answers: 57)
Asked on November 16, 2017 4:50 pm
34 views
Answers (2)
2
Private answer

I had this problem too. The root of the issue was the TLS 1.2 was disabled in the client machine.

Micro Focus is using .NET 4.0 version of framework for AutoPass clients. .Net Framework doesn't have the protocol TLS 1.2 enabled by default, so the solution is to enable the protocol with the registry key.

[HKEY_LOCAL_MACHINESOFTWAREMicrosoft.NETFrameworkv4.0.30319]
''SchUseStrongCrypto''=dword:00000001

[HKEY_LOCAL_MACHINESOFTWAREWow6432NodeMicrosoft.NETFrameworkv4.0.30319]
''SchUseStrongCrypto''=dword:00000001

Marked as spam
Posted by (Questions: 16, Answers: 801)
Answered on November 16, 2017 4:51 pm
That fixed it for us. Thanks!
( at November 16, 2017 4:52 pm)
1
Private answer

Hello Michaeldx,
I have tried to added the registry keys, but still it is throwing an the same error message as ''License server is not available'' for UFT 14.01 while accessing the license from AutoPass license server.
Thanks
Karthik

Marked as spam
Posted by (Questions: 0, Answers: 1)
Answered on December 18, 2017 2:33 pm