Cannot generate Live Analysis report for any project under one domain

  • Questions
  • Cannot generate Live Analysis report for any project under one domain
Question ID: 104936
2
0

I am posting the following issue that MrWhite managed to get a resolution for from sending him a copy of one of my affected projects. He will be including the fix. This is a pretty specific issue for our set of projects, but feeling was it might be able to help out others out there in case a similar problem was present.

QC11/ALM11

I am getting an error when attempting to add a graph via Live Analysis within the Test Lab. This issue seems to be occurring for multiple projects across just one domain. Other projects in a different domain do not have the issue.

In test lab, I pick a folder with a test set within it. Once the folder is highlighted, you can see the Details tab, Attachments tab, and the Live Analysis tab. Click on the Live Analysis tab and should see Add Graph option in middle of page. If I click on that, I get the graph wizard and attempt to do summary graph by clicking on Next (summary graph is the default choice). When I click on Next I get an error pop up that says "Item does not exist."

If I click on the OK button it gives you with the error, the display is then on step 2 of the wizard but the Group by field is set to none and x-axis is empty and grayed out with the drop down. I can't choose any value and am only left with option to close the wizard as it cannot finish.

Going through the dashboard direct has the same result. Things I have tried to get around this have been to create a new copy of one of the issue projects, leaving it in the domain with the affected projects, as well as moving it to the other domain. Same issue is seen. Verify and repair does not find issues with the original nor the copied project.

Marked as spam
Posted by (Questions: 104, Answers: 0)
Asked on April 1, 2013 8:37 pm
15 views
Answers (1)
3
Private answer

HP was quite helpful in nailing down this issue. Many thanks to Oscar!

The root cause appears to be caused by a negative value in the SF_ROOT_ID column in the SYSTEM_FIELD table. The TS_USER_04 field which was a product lookup list was the culprit. Upon examining the system field table, found what seems like the correct list at LS_ID of 96 and LS_NAME of 'Product'.

Value in system field table needs to be changed to match the value for the list.

First run this test in a dev/test environment and backup the schema before updating production.

Run following SQL: `UPDATE SYSTEM_FIELD SET SF_ROOT_ID = 96 where sf_root_id = -97`

Now run this line to update server side cache: `UPDATE SEQUENCES set SQ_SEQ_VALUE=SQ_SEQ_VALUE+1 WHERE SQ_SEQ_NAME='FIELDS_VERSION'`

After running each SQL statement, log out of site admin and log into the project. This should allow for the analysis to work.

Disclaimer:
The 96 value may not be accurate for all the projects affected. If this needs to be applied to more projects, please check the LISTS table for the correct value. You will need to identify a negative value as above, and then find the correct value to replace.

Sample SQL to identify correct value: `SELECT LS_ID, LS_NAME from LISTS where LS_NAME like '%Product%' and LS_FATHER_ID = 0`

Use the LS_ID returned from this query to plug into the first one in the place of 96 if it's different.

Marked as spam
Posted by (Questions: 1, Answers: 116)
Answered on April 1, 2013 8:41 pm