Cannot open QC/ALM after moving databases to new server
Question ID: 108611
0
0

The databases were moved from one server to another.

We did this so far:

– Added NEW DB server to list in DB Servers tab

– Created a NEW/blank project to confirm it worked.

Then, we did this for our projects:
Noted repository folder location

– Remove project

– DBA moved the project database and ran SQL-server stored procedure to "fix" the td user

– Modified the project DBID.xml file to point to the NEW DB server (with example from our newly created project from above)

– Restored project

– Tested to see if it still worked

We did this for 20 projects and all of them worked fine… We even figured out how to do the same process to move the Lab_Project.

When the DBA moved qcsiteadmin_db and we cycled our service, then the problems started happening!

When we tried to open QC/ALM after that was completed we received an error.

> HTTP: ERROR 500
>
> Problem accessing /qcbin/. Reason:
>
> Cannot build directory item for key
> ‘external_auth_type’ in TD Params
> Directory

Marked as spam
Posted by (Questions: 193, Answers: 14)
Asked on September 14, 2018 3:45 pm
124 views
Answers (1)
0
Private answer

You are definitely on the right track with the PROJECT moves.

see this post:

http://eyeontesting.com/questions/8824/how-to-get-our-existing-qc-server-to-use-a-new-dat.html

You did everything correct except for getting the QC/ALM service to know where the new location is for qcsiteadmin_db !

So follow those directions in the ''Modifying siteadmin.xml'' section to edit your siteadmin.xml file.

Now, you will also need to know how to ''re-Deploy with the Deployment Wizard''.
HP took the shortcut out of the Start Menu back in QC12.0, but here is a post to show you how to get it back and run it:

http://eyeontesting.com/questions/7795/where-is-the-link-for-server-deployment-wizard-on.html

Good Luck!

Marked as spam
Posted by (Questions: 4, Answers: 509)
Answered on September 14, 2018 3:52 pm
EyeOnTesting

Welcome back to "EyeOnTesting" brought to you by Orasi Software, Inc.

X
Scroll to Top