Error when attempting to create a defect from a manual run in test lab

  • Questions
  • Error when attempting to create a defect from a manual run in test lab
Question ID: 107360
1
0

Getting error when trying to submit a defect from an in progress manual run in test lab. The error is "object reference not set to an instance of object". This seems to appear for any user, as both testers and admins see same result from attempt at same action.

Does not seem client nor user group issue given different folks get same result. So would seem either test or set related. Any suggestions?

Marked as spam
Posted by (Questions: 26, Answers: 22)
Asked on January 23, 2017 2:59 pm
5 views
Answers (1)
1
Private answer

Hello,

I saw this mentioned in a HPE article. Issue is related to a step name in the test not having a name within the DB. Not sure if this is for the step at the time of the defect and failed action (that would lead to the step failing), or if any missing step name for any step with the test will impact.

Resolution from HPE (I would suggest having a DBA help with this):

Backup the project's database just in case of issue

Navigate to the project's DESSTEPS table

Run sql statement below

update DESSTEPS set DS_STEP_NAME = 'step_' + convert(varchar, DS_STEP_ORDER) WHERE DS_STEP_NAME IS NULL

This will replace the missing name (as represented by a NULL in the DB) with an appropriate name from step order in that particular test. With no step name missing at this point, the defect creation should work without issue.

Marked as spam
Posted by (Questions: 1, Answers: 116)
Answered on January 23, 2017 3:21 pm
That seemed to work as defect now is created. Will have to go back and examine some tests to see if this is a more widespread issue. These are imported from Excel so likely a user problem that needs addressing.
( at January 23, 2017 6:20 pm)