iOS devices not loading Agent files after upgrade from Mobile Center 3.00 to 3.20

Question ID: 109288
2
0

I recently upgraded my Mobile Center server from Mobile Center 3.00 to Mobile Center 3.20.

However, my iOS devices are not connecting to Mobile Center as I don’t see the Agent or Agent Launcher applications being loaded on the actual devices.

What have I done wrong?

Marked as spam
Posted by (Questions: 192, Answers: 1)
Asked on February 6, 2020 5:08 pm
14 views
Answers
2
Private answer

Please check your Connector.log file located in the Agent folder on your Mobile Center server.

You should see an entry showing you the versions of your Agent files. Here is an example:

[2019-08-26 12:13:43,232] [] [] [] []  [] [] [pool-39-thread-6] [INFO] [HPMC-iOS] got multi line result: [CFBundleIdentifier, CFBundleVersion, CFBundleDisplayName, com.google.chrome.ios, "55.0.2883.79", "Chrome", com.adt.myadtmobile, "2.1.12", "MyADT", com.apple.test.WebDriverAgentRunner-Runner, "3.20.00.00-12", "MC Runner", com.hp.alm.HPMC-AgentL, "3.00.00.00-14", "MC Launcher", com.hp.alm.HP4M-Agent, "3.00.00.00-14", "MC Agent"] (CLS=c.m.m.c.d.i.l.c.e.l.InstallAppCommand)
Please notice that the MC Runner file is 3.200.00-12 but the MC Launcher and MC Agent files are 3.00.00.00-14. If this is the case with your log file, you need to go back and resign the MC Agent and MC Agent Launcher files because you used the wrong original IPA files. You would have used the old MC 3.00 files instead of the MC 3.20 files.
Once the Agent files are resigned using the proper version, you will be able to connect your iOS devices to Mobile Center.
Marked as spam
Posted by (Questions: 1, Answers: 206)
Answered on February 6, 2020 5:21 pm