Is LRE 2020 a stable version to upgrade to?

Question ID: 109478
1
0

we are using PC 12.53

Marked as spam
Posted by (Questions: 218, Answers: 15)
Asked on April 28, 2020 11:25 am
31 views
Answers (1)
1
Private answer

Yes, We recommend upgrading to LRE 2020 SP1 (2020.1) on All machines

 

LoadRunner Enterprise 2020 SP1 (2020.1) version is distributed as a Full installation package

The installation process for LoadRunner Enterprise 2020 SP1 differs from previous upgrades and installations. You can install LoadRunner Enterprise 2020 SP1 as a clean installation, or as a service pack over LoadRunner Enterprise 2020 (the installation process is the same for both).

 

You can also migrate projects in ALM 12.60 directly to LoadRunner Enterprise 2020 SP1.

 

  • NOTE: if upgrading to LRE 2020. x from any PC 12.00 to 12.57 version , you MUST at least upgrade the ALM server (used for PC) to version 12.60 BEFORE you can migrate any old PC projects to the LRE 2020 or LRE 2020 SP1 environment.

 

LoadRunner Enterprise 2020 (LRE 2020 and  LRE 2020 SP1) is a MAJOR redesign and upgrade. LRE2020 is NOT a set of patches that can be applied on top of ALM-PC 12.63. It's a total redesign of LoadRunner Enterprise (formally known as Performance Center), that does not include an ALM server. The upgrade process does require the uninstalling of the old 12.63; PC server, ALL PC hosts, all Standalone LGs, and tester workstations ( VuGen, Analysis, or Full LR ) software, before installing the new LRE 2020 software.

 

All components must be upgraded to LRE 2020 or LRE 2020.1 before resuming any testing.

 

We Highly recommend that you have an Orasi Performance Engineer perform this major upgrade to LRE2020.x

 

NOTES:

  • LoadRunner Enterprise 2020.x version is distributed as a Full installation package.
  • If upgrading All Performance Center components/machines must be upgraded to same LRE 2020 or 2020.1 before working with the system again.
  • New Servers with clean Windows (fully updated) OS's are recommend for installing LRE 2020.x.
  • The ALM server will no longer be used with LoadRunner Enterprise 2020 and all future releases.
  • A Oracle or Microsoft SQL Database is still needed.
  • Make backups of the databases and project repositories BEFORE upgrading.
  • It is best to keep the ALM server 12.60 operational, until all projects have been moved to the new LRE2020 environment.
  • UAC must be disabled for the duration of the installation/upgrade process.
  • Set the DEP to AlwaysOFF to ensure the LRE2020 software installs property.
  • To install LoadRunner Enterprise 2020, you must have full local administrative rights on all of the designated LRE machines.
  • Read the LRE 2020 Requirements and Installation guides BEFORE starting
Marked as spam
Posted by (Questions: 12, Answers: 363)
Answered on April 28, 2020 11:28 am