Java versions supported for ALM 12.6x releases?

Question ID: 109038
0
0

Hello,

I wanted to find out what the Version 8 requirements behind the Java release for version 12.6x are?
We have frequent scanning of our systems for security issues and the release that was installed on the system when we installed ALM version 12.60 is version Java 1.8.101 – Which the Security center now wants it updated to 1.8.211 or higher.

Can you let me know what the supported release should be for certified level acceptance and whether or not this can be updated accordingly to our scans when it flags a Java release. (Meaning if it flags it next month because a new Java release is sent out – can it be updated without issue) ?

Also can it be Open JDK or doees it have to be only Oracle Java?

Thanks in advance,
HomerJ

Marked as spam
Posted by (Questions: 307, Answers: 11)
Asked on July 3, 2019 2:58 pm
9 views
Answers
1
Private answer

Hi HomerJ,
Here is the supported environments for all the current version: https://admhelp.microfocus.com/alm/specs/alm-qc-system-requirements.htm#ALM1260

Here is another post regarding the Java associated with ALM 12.6x: https://eyeontesting.com/questions/17585/is-there-anything-special-needed-to-upgrade-from-a.html

According to the documentation open and oracle JDK8 are both supported, but they don't have any further documentation to state what exact build is supported I just did an install using build 212 without issue. But i can't tell you for sure other supported builds of Java 8 that are supported beyond that as the documentation only states java 8 and no specific build (although 212 is the latest build available at this time)

I hope this helps,
Dan

Marked as spam
Posted by (Questions: 0, Answers: 701)
Answered on July 3, 2019 3:02 pm