Load Generators become randomly non-operational

  • Questions
  • Load Generators become randomly non-operational
Question ID: 105136
2
0

Currently using Performance Center 11.52, Load Generators become randomly non-operational. I will be upgrading to patch 1 as soon as possible. One of our projects is triggering the error. When I run the verify tool I do get errors that a repair should be run. Before I run the repair tool , I wanted to see if anyone could provide feedback. Any input would be great.

Marked as spam
Posted by (Questions: 151, Answers: 15)
Asked on October 8, 2013 5:12 pm
37 views
Answers (1)
0
Private answer

It would be becoase of any one or more of these reasons the ''Non-operational'' host is appearing:

1. A load test got stuck.
2. One or more of the 4 services running on the Performance Center host (Load Generator machine) is down. See below
3. If there is any maintenance taking place and to check the time slots

Since you have database needing the ''repair'' to be run we Highly recommend you complete the database maintenance BEFORE any more testing is done:

1. Ensure all users are out for ALM-PC
2. Double check no one is logged in to ALM-PC
3. Then go to site admin
4. Right click on the project -> Verify... wait until done
5. Right click on the project ->Repair... wait until done
6. right click on the project -> Upgrade...wait until done
7. Repeat this for ALL projects

To check services oh LGs

1. Please change the status of the host to ''operational'' on the Lab Management page.
2. RDP into the Performance Center host (or Load Generator machine)
3. restart all the 4 services.

* DataCollectionAgent

* RemoteManagement Agent Service

* Performance Center Agent Service

* Performance Center Load Testing Service

4. If the above suggestions do not help, then delete the problematic host and add it back.

Marked as spam
Posted by (Questions: 12, Answers: 363)
Answered on October 8, 2013 5:25 pm