Object Repository toolbar missing after upgrading from UFT 12.01 to 12.53?

  • Questions
  • Object Repository toolbar missing after upgrading from UFT 12.01 to 12.53?
Question ID: 107406
1
0

Odd one here… I have a Windows 7 machine, and I did an in-place upgrade of UFT 12.53 over 12.01. When I open the Object Repository (either from the menu or hitting Ctrl+R), the toolbar is missing. I’ve seen missing toolbars in QTP in the past that could be reset, but I’m not seeing anything similar for the OR in this version? Anyone run into this?

Marked as spam
Posted by (Questions: 359, Answers: 26)
Asked on January 26, 2017 12:41 pm
6 views
Answers (1)
1
Private answer

Definitely recommend a full manual clean uninstall/reinstall:

https://softwaresupport.hpe.com/group/softwaresupport/search-result/-/facetsearch/document/KM00319750

If you need to try a quick fix in the meantime, try this:

1) Close UFT.

2) Navigate to %APPDATA%HPQuickTest Professional

3) Rename each file that exists (e.g., rename ORMSettings.xml to old_ORMSettings.xml, etc.):

- ORMSettings.xml
- ORMToolBarLayout.xml
- ORQTUISettings.xml
- ORQTUIToolBarLayout.xml

4) Open UFT. The above files will automatically be recreated to default settings, and your OR and ORM toolbars/layout should be restored.

Marked as spam
Posted by (Questions: 0, Answers: 707)
Answered on January 26, 2017 12:43 pm
Thanks a bunch! I did the quick fix and it worked great. I'll do a manual clean uninstall at some point, just in case I have more conflicting legacy files on my machine.
( at January 26, 2017 12:44 pm)