Publicly shared graphs not updating

Question ID: 108410
0
0

I have created a graph in ALM and copied the Public URL and pasted it into a word document. When I open the link the changes are not reflected. I looked through he User Guide and found that there is a Site Parameter that needs to be added GRAPH_RESULT_LIFESPAN. I added the parameter and give it the lowest value possible which according to the documentation in the Help Center (https://admhelp.microfocus.com/alm/en/12.55/api_refs/site_params/metadata.htm ) is 1 minute. The graph is still not updating. Please help!!!

Marked as spam
Posted by (Questions: 103, Answers: 7)
Asked on May 18, 2018 3:24 pm
8 views
Answers (1)
0
Private answer

There is an error in the documentation for the GRAPH_RESULT_LIFESPAN parameter. The documentation should read the following...

***GRAPH_RESULT_LIFESPAN***

Description: The number of minutes a cached graph result is valid.

Min value: 5

Max value: 60

*Possible Values: increments of 5*

Introduced in release: ALM 11.50

Introduced in patch: GA

System: false

So the default value is 60 which would update the graph every 60 minutes. When you add the Site Parameter if the value is set too low the parameter has no affect. Once you set the parameter value to an positive increment of 5 (ex. 5, 10, 15, 20) it will start working. Any graph public URLs that that were created before will not update until the current 60 minute cycle is complete and then after that they will update at the interval specified in the Site Parameter. Any new URLs created (graphs that you have never shared a URL previously) will update at the interval specified in the Site Parameter. To get graphs that were previously shared to update at the specified URL immediately you will have to go into Share Analysis Item and select **Reset Analysis Item Public URL** and then copy the public URL again.

***You may need to restart the ALM service to make the parameter changes take affect.***

Attached is a Micro Focus KB article that talks about this...[link text][1]

[1]: /storage/temp/823-the-parameter-graph-results-lifespan-is-not-updati.pdf

Marked as spam
Posted by (Questions: 0, Answers: 297)
Answered on May 18, 2018 3:31 pm
Not updating as quickly as I would like but it will have to do... Thank you!!!
( at May 18, 2018 3:33 pm)