QC11 – Can’t do text search – indexing lost

  • Questions
  • QC11 - Can't do text search - indexing lost
Question ID: 104781
2
0

Recently I had a request to change the name of a domain. Since domain name change isn’t an option in QC Site Admin, I instead created a new domain with the correct new name, and then copied over the pre-existing project from the old domain to the new.

Now users have been up in the project in the new domain for about a week, and one user is complaining that text search doesn’t work – when attempting to text search in the requirements module, she gets a message that says "Text search is unavailable for this project. Contact the site administrator."

Text search is, in fact, enabled for the new project. I tried to Enable/Rebuild Text Search, though, and received a failure message.

How can this be fixed?

Marked as spam
Posted by (Questions: 372, Answers: 39)
Asked on December 31, 2012 4:30 pm
14 views
Answers (1)
2
Private answer

Firstly, in the future, you can just drag/drop your project from one domain to another in Site Admin, and QC will do the rest.

Second, if you're receiving an error when selecting Enable/Rebuild Text Search from Site Admin, try having your DBA manually rebuild the QCFTCAT Full Text Catalog. In SQL Server, using SQL Server Management Studio, have the DBA identify and navigate to the affected project database. Expand the database and go to Storage -> Full Text Catalogs -> QCFTCAT. Right-click QCFTCAT and choose 'Rebuild.'

Marked as spam
Posted by (Questions: 0, Answers: 720)
Answered on December 31, 2012 4:31 pm
That worked! Manually rebuilt the QCFTCAT on the database and users can now do full text search. Thanks!
( at December 31, 2012 4:32 pm)