QC12.xx – How can I ”restore” a LAB_PROJECT even though using Enterprise License?

  • Questions
  • QC12.xx - How can I ''restore'' a LAB_PROJECT even though using Enterprise License?
Question ID: 108769
0
0

We somehow messed up our LAB_PROJECT and are getting errors relating to it.
We DO have the old QC11.52 server and it has the Lab_Project database and repository.

Can we just "restore" it like we do for other projects and then do a verify/repair/upgrade?

Marked as spam
Posted by (Questions: 80, Answers: 5)
Asked on December 18, 2018 5:44 pm
22 views
Answers (1)
0
Private answer

YES! as a matter of fact you can!
I assume you are using an ''Enterprise'' license since you refer to it as ''QC''.

If using Enterprise license:

First, you need to add the site parameter:
SHOW_LAB_PROJECT=Y

Then you can see the existing LAB_PROJECT in the site projects list/tree (if it exists).
Then you can ''remove'' it and ''restore'' the other one as you usually do with other projects.
You can also do verify/repair/upgrade and ''activate'' as usual.

If using an ALM license:

You can see the ''Lab Management'' tab.
Here you can do remove/restore (careful with restore as you must use the BUTTON from the button bar for that), verify/repair/upgrade and ''activate'' as usual.

Since LAB_PROJECT is really only used with the ALM license, you can remove the site parameter (or set to ''N'') from an Enterprise License instance after it is working again.

Marked as spam
Posted by (Questions: 3, Answers: 485)
Answered on December 18, 2018 6:11 pm