With ALM 12.6 will we be able to go to a more recent version of Jetty? If so, what is the version?

  • Questions
  • With ALM 12.6 will we be able to go to a more recent version of Jetty? If so, what is the version?
Question ID: 108770
0
0

With ALM 12.6 will we be able to go to a more recent version of Jetty?

Marked as spam
Posted by (Questions: 185, Answers: 13)
Asked on December 18, 2018 6:45 pm
5 views
Answers (1)
0
Private answer

Sorry, ALM12.60 uses an **embedded Jetty server 9.1.4, and cannot be upgraded manually.**

NEW with ALM 12.6, though is that you MUST pre-install you own load of JAVA 8, THEN install ALM 12.6.

We have seen a few situations where admins have tried adding IIS layer and have later wished they did not (random failures due to Windows updates) - Jetty seems to be working well for most.

This is all there is in the Sys-req's - about JAVA and Apache (Jetty is implied in the application server part):
https://admhelp.microfocus.com/alm/specs/alm-qc-system-requirements.htm

JDK/JRE:
Oracle Java 8
Open JDK 8 ALM12.60/Patch01

Application Server (JETTY by default):
The Application server functionality is now built in to the ALM/QC platform *and there is no need to install a third party application server* (WebLogic, WebSphere, and JBoss) from version 11.50 and later. The Micro Focus ALM application server uses JDK8 (1.8) and supports 64 bit JVM.

(other) Web Servers:
Apache 2.2
Apache 2.4.x
Microsoft IIS 7.5
Microsoft IIS 8.0
Microsoft IIS 8.5
Microsoft IIS 10

NOTE:

- By default, application servers
include HTTP servers. If you need
additional functionality a web server
can be added
- Micro Focus will certify the major and minor releases of Apache (e.g. Apache 2.2) while all minor-minor releases of Apache (e.g. version 2.2.x) will not undergo specific certifications as it is expected that minor-minor software releases from Apache will maintain full compatibility

Marked as spam
Posted by (Questions: 3, Answers: 466)
Answered on December 18, 2018 6:51 pm