Site Parameter EXCEL_ADD_IN_GROUP not working

  • Questions
  • Site Parameter EXCEL_ADD_IN_GROUP not working
Question ID: 108559
0
0

I am trying to set up the Site Parameter EXCEL_ADD_IN_GROUP but it does not appear to be working as I read it.
Description: This parameter specifies a user group name, only the users who are in this group have permission to access the Excel add-in.
So I added this Site Parameter…see attached…and created a group but put no one in the group…I can open Excel…login to the noted project and upload Defects…but I should not because I am not a member of the Excel AddInGroup.
Am I missing something?

![alt text][1]

[1]: /storage/temp/868-excel-addin-group-parameter.png

Marked as spam
Posted by (Questions: 199, Answers: 1)
Asked on July 29, 2018 4:42 pm
13 views
Answers (1)
0
Private answer

GoDawgs,

This parameter is no longer supported after ALM 12.50. Here is the explanation from MicroFocus:

EXCEL_ADDIN_GROUP
Possible values: User group name
Default value: N/A
Description: This parameter specifies a user group name, only the users who is in this group have permission to access the Excel add-in

NOTE:
Above parameters are only available for the following ALM/QC versions/patches:

* ALM 11.0 Patch 19
* ALM 11.52 Patch 06
* ALM 12.01 Patch 02
* ALM 12.21 Patch 01
* ALM 12.50 GA

So, from ALM 12.53 onward, only the following groups can upload from Excel:
(ALM default groups: QATester, TDAdmin, Project manager).

EXCEL_ADDIN_GROUP parameter is implemented for ''Excel legacy add-in'' (12.01),
This parameter is not supported for REST based ''Excel Upload Add-in'' (12.2x to 12.5x)
It is risky to implement with REST add-in.

It has been forwarded to MicroFocus R&D as an Enhancement Request and is under Review.

Marked as spam
Posted by (Questions: 1, Answers: 213)
Answered on July 29, 2018 4:53 pm