TruClient Ajax IE – Object Not Found

  • Questions
  • TruClient Ajax IE - Object Not Found
Question ID: 106011
0
0

Hi Everyone,

Working on Ajax-heavy Web-based .NET application launching app. I’m using TruClient for IE protocol in IE9 mode (supported). The interface of the application launching app is modeled after the Windows 8 "Metro" with clickable tiles, where clicking each tile launches a different application. I’m able to use the Metro-style interface manually, and to record *and run* my scripts in VUGen w/o issue. However, when running a smoke test on my controller (which does have a load generator configured) I consistently get an "Object Not Found" error when I click on a particular tile to launch the target application. I’ve done extensive research and attempted the following:

– Wait Functions
– Verify Functions
– Modifying the end events of the target and previous
– Changing ID Method
– Highlighting
– Improving Object ID
– Alternative steps (N/A)

I’ve also tried verifying on other static elements on the page and they consistently fail, which leads me to think that the page simply isn’t loading. Might any of you performance testing gurus have any recommendations for how I might proceed?

LR ver 11.52

Thanks,
Chris

Marked as spam
Posted by (Questions: 2, Answers: 0)
Asked on April 23, 2015 3:25 pm
11 views
Answers (2)
0
Private answer

Make sure that you IE version on your load generators match the version upon which you recorded the application.

Marked as spam
Posted by (Questions: 4, Answers: 41)
Answered on April 29, 2015 8:20 pm
0
Private answer

I am facing the same issue. I am using Ajax truclient Ie protocol with LR 12.01. And having IE 11 installed in my machine. The load generator also has same IE version instaaled. Did u get any solution for this? @Chris-ABM

Marked as spam
Posted by (Questions: 0, Answers: 1)
Answered on July 3, 2015 4:56 pm