UFT API Script Error when try to update

  • Questions
  • UFT API Script Error when try to update
Question ID: 107837
1
0

We are having issue with UFT script when trying to update and save giving us error("An unexpected error occured."). Not able to update/change any of the script. Also tried with different VM and User but still got the same error. And even when we try to create a new script it is giving us the same error.
This issue just start couple weeks ago and I have not change UFT or the system.

Looking at the details of the error message I see that it is related to System.IO.Exception with description.

"The process cannot access the file ‘Script.dll’ because it is being used by another process."

Marked as spam
Posted by (Questions: 22, Answers: 6)
Asked on August 11, 2017 8:10 pm
6 views
Answers (1)
0
Private answer

I have seen similar issue before working with Anti Virus tools. This time the AV tool was CarbonBlack and when user disabled it UFT started working as before. Most AV block files that are newly compiled and UFT compiles the API test into script.dll which can cause issues with AV tools. I recommend looking in to AV tools and disabling AV for a validation then working with the AV team on how to get a permanent solution. need to re open it.

Marked as spam
Posted by (Questions: 2, Answers: 98)
Answered on August 11, 2017 8:10 pm