UFT first test script runs from ALM test lab always fails

  • Questions
  • UFT first test script runs from ALM test lab always fails
Question ID: 108492
0
0

Hello,

UFT first script is always failing when run from ALM test lab but same test case runs successfully when run directly from UFT. We have tried with wait time, but still got the same result.

We are using UFT 12.54 patch 5 and ALM 12.01 in remote desktop with OS Windows 2008 Server R2.
AUT is Delphi Version 2009.

Any suggestions ?

Marked as spam
Posted by (Questions: 26, Answers: 0)
Asked on July 16, 2018 12:41 pm
5 views
Answers (1)
0
Private answer

Hello,

There are a couple of things you can look at to try to solve this issue.

1) Recommended to load only required Add-ins i.e Delphi & web in your case.
You can set the add-in via the Test Settings but then you have to do that for each test. This way, the Delphi & Web add-in is loaded automatically.

2) Try to ran IE as Admin : Right click IE and select Run As Administrator when you launch QC/ALM, this usually causes the applications (i.e UFT that are opened by ALM to also run elevated) and execute UFT script from ALM Lab.

3) Uncheck the 'Run UFT in hidden mode' in Remote Agent settings. Do one of the following:

- Select Start > All Programs > HPE Software > HPE Unified Functional Testing > Tools > Remote Agent. The Remote Agent opens and the Remote Agent icon is displayed in the task bar tray.

- Right-click the Remote Agent icon and select Settings. The Remote Agent Settings dialog box opens.

- Uncheck the selection box 'Run UFT in hidden mode'

Marked as spam
Posted by (Questions: 0, Answers: 27)
Answered on July 16, 2018 1:16 pm