UFT/QTP – Unable to connect testing tool to the requested ALM/QC server
Question ID: 106652

When ALM/QC tries to launch any of my UFT/QTP hosts via Automatic Runner, I receive the error:

"Unable to connect testing tool to the requested ALM/QC server"

I’ve tried all of the normal fixes to no avail:

-Refresh ALM/QC client components, connectivity, and registration

-Re-installed UFT/QTP plugin/add-in for ALM/QC

-Reconfigured DCOM settings

-Made sure "Allow other HP products to run tests and components" is checked/enabled

-Run UFT/QTP and Remote Agent as Administrator

-Double-checked the UFT/QTP affected host machines have the proper minimum permissions to work with ALM/QC

-Not using RDP; the affected machines are locally logged in

-Verified the affected machines are NOT locked nor logged off

-Made sure nothing is being blocked via firewalls between my ALM/QC application server and UFT/QTP host machines

-Using LSFORCEHOST environment variable on all affected hosts

Please help!

Marked as spam
Posted by (Questions: 424, Answers: 91)
Asked on January 29, 2016 2:08 pm
Answers (1)
Private answer

Are you by chance using LDAP authentication for your ALM/QC server? Perhaps double-check your password didn't change and conforms to acceptable characters allowed.

Marked as spam
Posted by (Questions: 0, Answers: 771)
Answered on January 29, 2016 2:09 pm
That was it! I changed my password and retested and it now works. There must be some delimiter issue in ALM_QC / Automatic runner / and QTP/UFT that cannot handle passing certain characters. My password worked for logging directly in ALM_QC from the client and QTP/UFT plus our network and other systems.
( at January 29, 2016 2:09 pm)

Welcome back to "EyeOnTesting" brought to you by Orasi Software, Inc.

Scroll to Top