We are getting ”Installer can’t run on Windows NT” error with Configuration Wizard when installing 11.52

  • Questions
  • We are getting ''Installer can't run on Windows NT'' error with Configuration Wizard when installing 11.52
Question ID: 105324
0
0

We just downloaded ALM11.52, installed it on Windows2012 server R2 (standard), and after it finished installing the "platform", and tried to launch the configuration Wizard, we are getting an unexpected "Installer can’t run on Windows NT" error. This server is a Windows 2012 Server R2 (standard) executing the setup.exe in the Win64 folder of the download.

Please help.

Marked as spam
Posted by (Questions: 191, Answers: 14)
Asked on March 10, 2014 10:21 pm
7 views
Answers (1)
0
Private answer

You are experiencing the ''time capsule'' problem with QC.
When the unpatched (or GA) version of QC is released, they only support known various operating systems and DB server versions at that time. As newer patches come out, they often add support to newer OS versions and DB server versions.

In your case, QC11.52 Patch 2 adds support for Windows Server 2012 R2.

So, in this situation, since your OS is NEWER than supported by the ''GA'' version QC installer, but you know it will be supported as soon as you get Patch 2 on the QC server, there is a ''switch'' to avoid the OS ''validation''.

So, the Configuration Wizard is launched (on Windows) by the BAT file ''run_after_install.bat'', which is located in the QC Install folder'' (something like c:program filesHPHP Application Lifecycle Management 11.52''.

Find this line in that file (edit with notepad) and take the ''rem'' out of the line:
rem set SKIP_VALIDATIONS=-wOsValidator -wLicenseTypeValidator

Then run the BAT file to get the Configuration Wizard to come up again.

Make sure to patch to the patch supporting your OS version before actually using QC.

Marked as spam
Posted by (Questions: 3, Answers: 488)
Answered on March 10, 2014 10:30 pm