Workflow error in the template project created from en existing project

  • Questions
  • Workflow error in the template project created from en existing project
Question ID: 108020
0
0

Hello. We are receiving the following error in our template project that has been created by copying the customizations from an existing project. We are currently using ALM 12.21.18 Patch 2, and the issue doesn’t occur in the existing project, but it does in the template project that is created from that project. After creating the template, I access the script editor where I am prompted to convert the custom workflow that was copied over from the originating project. After I convert the workflow, check the syntax, and save all the changes, I receive the following error when I return back to the modules within ALM.

"A failure has occurred in the workflow script (in function )."

The message indicates that the error is on line 4742 within the Template_Notification_Configuration_Incomplete function. When I access the function within the script editor, the line indicated in the error is located on line 1 in the workflow within the ‘Template Common Script’ module. I then checked for line 4742 within the Template_Notification_Configuration_Incomplete function, and it doesn’t exist. Can you help me with this issue?

Marked as spam
Posted by (Questions: 217, Answers: 21)
Asked on December 4, 2017 9:52 pm
8 views
Answers (1)
0
Private answer

I have have seen this issue before, and I received the following work around from Micro Focus, that should resolve the issue for you. Be sure to try this in your test environment before making any changes within your production environment. The steps below will walk you through the work around.

If you are creating a template from an existing project with custom workflow:

- Create the template project by copying the customizations from the existing project
- Convert the workflow --> Perform Syntax check --> Click 'File' --> 'Save All'
- Access Site Admin --> Select the template project --> Click the 'Linked Projects' tab
- Delete the project link in the 'Linked Projects' in Site Admin
- Access Customization --> Workflow --> Script Editor
- Delete all of the custom workflow within the 'Project Scripts' in the Script Editor
- Click 'File' --> 'Save All'
- Return back to the module

If the template project has aready been created and the workflow has been converted in the new template project:

- Access Site Admin --> Select the template project --> Click the 'Linked Projects' tab
- Delete the project link in the 'Linked Projects' in Site Admin
- Access Customization --> Workflow --> Script Editor
- Delete all of the custom workflow within the 'Project Scripts' in the Script Editor
- Click 'File' --> 'Save All'
- Return back to the module

After you have performed the steps listed above, retest to see if the issue still occurs.

Marked as spam
Posted by (Questions: 2, Answers: 278)
Answered on December 4, 2017 9:53 pm