ALM Upgrade, LDAP users missing, some added back with project restore, but blank info.

  • Questions
  • ALM Upgrade, LDAP users missing, some added back with project restore, but blank info.
Question ID: 108471
0
0

We just upgraded our ALM site admin (qcsiteadmin_db) from 11.52 to 12.21 then to 12.55.

We noticed that out of 1703 ALM LDAP users from current ALM 11.52 production only about 850 users showed up on 12.55 version. why is this?

When I migrate and upgrade projects (11.52 to 12.55 with restore, then verify/repair/upgrade) more users get added to site admin, however users details were missing (full name, email, phone, description etc.)

Any idea why this is happening? Is it related to the updated functionality of LDAP in 12.20 ?

Marked as spam
Posted by (Questions: 76, Answers: 4)
Asked on July 9, 2018 4:41 pm
8 views
Answers (1)
0
Private answer

This is normal behavior on added users during project RESTORE.
If users of project are not already in Site Admin list, it adds the USERID, but no other info is known, so it is blank.

As for missing various LDAP users, it is likely due to WHEN the LDAP tree was read in originally vs. reading the tree now.
Over time, users come and go in the tree and if the LDAP filter was used, some ,may not show up now.

Be careful!
When QC adds a user from the restore process, it only adds the USERID to the list, but does not follow up with the remaining LDAP ''credentials'' part - this must be done manually or via LDAP user import filter.

If a new USERID remains with blank ''distinguished name string'' (used by LDAP to authenticate), the user will never be able to login.

Marked as spam
Posted by (Questions: 3, Answers: 472)
Answered on July 9, 2018 4:47 pm