Defect user licenses give permission error though user group has the correct permissions

  • Questions
  • Defect user licenses give permission error though user group has the correct permissions
Question ID: 107329
1
0

We have acquired some new defect only user licenses. I setup a new user group and set permissions for the defect only users. All the correct permissions are set. However when they attempt things in Defects, things such as changing status, they get message "you don't have permissions to execute this action". I can see update settings are set. What are we doing wrong? This is ALM 12.53.

Marked as spam
Posted by (Questions: 104, Answers: 0)
Asked on January 9, 2017 4:13 pm
5 views
Answers (1)
1
Private answer

Hello,

Do you know if the custom group created for your defect users used TdAdmin as the base during creation? As a new custom user group is created, you are prompted to choose a default group as the base to preset the permissions. You then edit the permissions after creation.

I ask as it is a best practice now to use the TdAdmin group as the base for all custom groups. Then remove down the permissions to fit your need. Groups created from the other default groups are very often having issues such as checked permissions being ignored or conflicts with actions (such as when filters are in use).

If you do not know which base was used, I suggest you create a new user group based from TdAdmin and then reduce the permissions for your defect only users. Add a user in and test to be sure actions work as expected. This is a very common issue these days and I would wager your existing group did not use TdAdmin as base during creation.

Marked as spam
Posted by (Questions: 1, Answers: 116)
Answered on January 9, 2017 4:14 pm
Recreating the group using tdadmin as base fixed the error issue. Good thing to know. I deleted my prior group then as it is no longer of use.
( at January 9, 2017 4:32 pm)