Error failed to send virtual key “15”

Question ID: 109463
0
0

We are using  LoadRunner 12.62 with  Windows Server 2016. We are using the SAP protocol.

We are encountering failures when we run our script on an AWS machine due to “Failed to send virtual key 15 error”. When running the script from VuGen on a different machine there are no errors and the script runs fine.. Any thoughts on how to resolve this issue would be great.

Marked as spam
Posted by (Questions: 156, Answers: 15)
Asked on April 26, 2020 10:08 am
8 views
Answers (1)
0
Private answer

There can be many reasons that cause this issue. One of the most common reasons, is that the scripts were created on different client machines. When creating and replaying scripts ensure that the SAPGUI Clients are setup/configured the same for scripting.

In order to resolve this issue, I recommend the following:

  • If LoadRunner scripts are running in multiple SAP environments, ensure the environments are setup/configured properly to replay your scripts
  • Before running a load test, ensure you can manually bring up a browser and manually execute your business processes on your load generators
  • On one of your load generator machines, install the LoadRunner Full setup.
    • This will allow you to run the script in VuGen to insure the script works on your

LG machine before running a load test.

  • Ensure that the User profiles are setup correctly as different users may have different profiles / privileges.

I hope this helps.

Marked as spam
Posted by (Questions: 17, Answers: 263)
Answered on April 26, 2020 10:10 am