iOS devices fail to load application in Mobile Labs

  • Questions
  • iOS devices fail to load application in Mobile Labs
Question ID: 108561
0
0

We’re having problems loading our application onto iOS devices. We double checked certificates and provisioning profiles and couldn’t resolve the issue. Below is the error we’re getting:

The application installation failed. It can be attempted again but the application's saved data will be lost. Notice: Application failed to install to device iPhone 6 Plus: 'Codesign exited with code 1. Command line: -fsCF9E1C2E8460A63420F7A2B5266572B0A6861335 trust.dylib(/tmp/deviceConnect-hub-g1fej4pk.yyp/Payload/FirstBank.app) Output: trust.dylib: replacing existing signature trust.dylib: errSecInternalComponent '

Marked as spam
Posted by (Questions: 199, Answers: 1)
Asked on July 31, 2018 4:23 am
6 views
Answers (1)
0
Private answer

GoDawgs,

Mobile Labs provided the following solution:
On the deviceConnect server:
Open keychain access.
Locate your developer certificate.
Is it in Login or System?
If it's not in System, copy or move it there.
Now expand it so that you can view the private key.
Double click the private key and select ''Access Control''

Ensure that ''Allow all...'' is selected and click OK.
If you needed to change it, you will be prompted for the DeviceConnect account and it's password a couple of times.
Then try to connect to the device again

Marked as spam
Posted by (Questions: 1, Answers: 213)
Answered on July 31, 2018 4:26 am