QTP was launched without permission to interact with the desktop

  • Questions
  • QTP was launched without permission to interact with the desktop
Question ID: 104851
1
0

Hello,

I’m trying to execute a QuickTest Pro automated test from a local instance of Quality Center 11 to a remote host where QTP 11 is installed. I setup DCOM using the script provided in [this HP knowledge base article](http://support.openview.hp.com/selfsolve/document/KM187086). It works on one test machine but fails on another. The error returned in the log is the following:

General Run Error: QuickTest Professional was launched without permission to interact with the desktop.

When I run Quality Center on the machine where QTP is installed and choose "run all tests locally", it works perfectly. Both machines are on the same domain and can ping each other. I tried different combinations of DCOM settings but nothing worked so far.

Did anyone ever experience this issue? Also, any information regarding how these DCOM settings work would be appreciated.

Thanks in advance!

**Update**: As mentioned, if I run Quality Center on the machine where I want to execute the test and check "Run all tests locally", it runs the test as expected. Once done, I can suddenly launch tests remotely from the other machine just fine! Then, if I go to the task manager and kill AQTRmtAgent.exe, remote test execution stops working. The problem seems to occur when AQTRmtAgent is being launched.

Marked as spam
Posted by (Questions: 3, Answers: 0)
Asked on February 12, 2013 10:19 pm
32 views
Answers (2)
0
Private answer

Here's an article from HP about this issue:

Knowledge document information

Title:Error: ''QTP was launched without permission to interact with desktop''

Document ID: KM204270

Product: QuickTest Professional

Version:
OS: Unspecified
Updated: 2007-Sep-11

The user receives the following error message when running a QuickTest Professional (QTP) script remotely from Quality Center:

''QTP was launched without permission to interact with desktop''

**Diagnosis**: Remote computer is connected to another computer desktop (using PCAnywhere/Terminal Services/Remote Desktop) and currently the other desktop is active.

**Solution**
Physically login to remote machine
When doing a remote execution, the target machine must be physically logged in.

I hope that helps.

Marked as spam
Posted by (Questions: 16, Answers: 759)
Answered on February 12, 2013 10:44 pm
Thanks for the response. I am, indeed, connecting to the machine through remote desktop (mstsc). However, I'm currently able to execute tests remotely to many other machines that I connect to using mstsc. This specific machine is the only one where it does not work. And, unfortunately, physical connection is not an option in this context.
( at February 12, 2013 11:07 pm)
0
Private answer

To Add to what Michaeldx has posted.

to execute as a remote host someone has to be logged into the machine. typically this is a a generic local admin user for testing. This is not the same as logging in and running the tests locally. If this is a virtual machine there is a setting or a way to have the VM act as if it has a user logged into it without actually RDPing into the machine.

In addition Screen savers and Locking the machine will generate the same error on the machine as well.

EDIT: I also just noticed that if the remote host is connected to another machine through RDP, you will also get this error, if the RDP window is the active window.

Marked as spam
Posted by (Questions: 1, Answers: 69)
Answered on February 13, 2013 1:21 pm
I'm RDPing to the host and logging in as a local admin user. I then try to launch the test on that host from my own machine using QC. It works for every machine except this one. The machine isn't locked and there are no screen saver running. I need to figure out what's different about this machine but I'm not quite sure where to start.
( at February 13, 2013 2:55 pm)