Select Tests for Test Lab for a set shows just empty folders from test plan

  • Questions
  • Select Tests for Test Lab for a set shows just empty folders from test plan
Question ID: 107685
2
0

Having an issue with adding tests to a test set as no tests are there to pick from. When I go to select tests, the folder structure is there, but the folders are empty. In test plan the tests are present. Other test sets I can add find so I know permissions are set fine for my user. Also no filters are in use and I even tested with a different user login and had same issue. Is this test set just corrupt in some way?

Marked as spam
Posted by (Questions: 56, Answers: 1)
Asked on June 22, 2017 1:36 pm
4 views
Answers (1)
2
Private answer

Hello,

Given what all you have checked already, I would suggest taking a look at the test set type value that is set for the test set that you don't see tests to add to.

Test set type options are default, performance, functional and external.

If you for example have the test set type set to functional, then only automated tests can be added. ALM would only filter then for that based on the test set type. Manual tests would not be available to add so they would not show up under the Select Tests Test Plan Tree tab view. Default would be the type you want in place for manual tests, and default also allows for automated test add as well.

Marked as spam
Posted by (Questions: 1, Answers: 116)
Answered on June 22, 2017 1:38 pm
That was it. The set was Functional type and thus stripped out manual tests from the Select Test tree view. I changed it to Default and now all the tests are there to be selected and added. Thanks!
( at June 22, 2017 4:37 pm)